Ubuntu

21.04

支持的架构:arm64、x86-64。

1、下载 NGINX 签名密钥,并将其添加到 apt keyring中:

# curl -sL https://nginx.org/keys/nginx_signing.key | # apt-key add -

这一操作可消除安装过程中出现的安 packages cannot be authenticated 装包无法验证的警告。

2、要配置 Unit 存储库,请创建以下名为 /etc/apt/sources.list.d/unit.list 的文件:

deb https://packages.nginx.org/unit/ubuntu/ hirsute unit
deb-src https://packages.nginx.org/unit/ubuntu/ hirsute unit

3、安装所需核心包及其他包:

# apt update
# apt install unit
# apt install unit-dev unit-go unit-jsc11 unit-jsc15 unit-jsc16 unit-jsc17 \
​       unit-perl unit-php unit-python2.7 unit-python3.9 unit-ruby

20.10

支持的架构:arm64、x86-64。

1、下载 NGINX 签名密钥,并将其添加到 apt keyring中:

# curl -sL https://nginx.org/keys/nginx_signing.key | # apt-key add -

这一操作可消除安装过程中出现的安装包无法验证的警告。

2、要配置 Unit 存储库,请创建以下名为 /etc/apt/sources.list.d/unit.list 的文件:

deb https://packages.nginx.org/unit/ubuntu/ groovy unit
deb-src https://packages.nginx.org/unit/ubuntu/ groovy unit

3、安装所需核心包及其他包:

# apt update
# apt install unit
# apt install unit-dev unit-go unit-jsc11 unit-jsc13 unit-jsc14 unit-jsc15 \
​       unit-perl unit-php unit-python3.8 unit-ruby

20.04

支持的架构:arm64、x86-64。

1、下载 NGINX 签名密钥,并将其添加到 apt keyring中:

# curl -sL https://nginx.org/keys/nginx_signing.key | # apt-key add -

这一操作可消除安装过程中出现的安装包无法验证的警告。

2、要配置 Unit 存储库,请创建以下名为 /etc/apt/sources.list.d/unit.list 的文件:

deb https://packages.nginx.org/unit/ubuntu/ focal unit
deb-src https://packages.nginx.org/unit/ubuntu/ focal unit

3、安装所需核心包及其他包:

# apt update
# apt install unit
# apt install unit-dev unit-go unit-jsc11 unit-perl \
   unit-php unit-python2.7 unit-python3.8 unit-ruby

19.10

警告

Unit 1.20+ 包不适用于 Ubuntu 19.10。该发行版已过时;请更新。

支持的架构:x86-64。

1、下载 NGINX 签名密钥,并将其添加到 apt keyring中:

# curl -sL https://nginx.org/keys/nginx_signing.key | # apt-key add –

这一操作可消除安装过程中出现的安装包无法验证的警告。

2、要配置 Unit 存储库,请创建以下名为 /etc/apt/sources.list.d/unit.list 的文件:

deb https://packages.nginx.org/unit/ubuntu/ eoan unit
deb-src https://packages.nginx.org/unit/ubuntu/ eoan unit

3、安装所需核心包及其他包:

# apt update
# apt install unit
# apt install unit-dev unit-go unit-jsc11 unit-perl \
   unit-php unit-python2.7 unit-python3.7 unit-python3.8 unit-ruby

18.04

支持的架构:arm64、x86-64。

1、下载 NGINX 签名密钥,并将其添加到 apt keyring中:

# curl -sL https://nginx.org/keys/nginx_signing.key | apt-key add –

这一操作可消除安装过程中出现的安装包无法验证的警告。

2、要配置 Unit 存储库,请创建以下名为 /etc/apt/sources.list.d/unit.list 的文件:

deb https://packages.nginx.org/unit/ubuntu/ bionic unit

deb-src https://packages.nginx.org/unit/ubuntu/ bionic unit

3、安装所需核心包及其他包:

# apt update
# apt install unit
# apt install unit-dev unit-go unit-jsc8 unit-jsc11 unit-perl \
   unit-php unit-python2.7 unit-python3.6 unit-python3.7 unit-ruby

16.04

警告

Unit 1.24+ 包不适用于 Ubuntu 16.04。该发行版已过时;请更新。

支持的架构:arm64、i386、x86-64。

1、下载 NGINX 签名密钥,并将其添加到 apt keyring中:

# curl -sL https://nginx.org/keys/nginx_signing.key | apt-key add -

这一操作可消除安装过程中出现的安装包无法验证的警告。

2、要配置 Unit 存储库,请创建以下名为 /etc/apt/sources.list.d/unit.list 的文件:

deb https://packages.nginx.org/unit/ubuntu/ xenial unit
deb-src https://packages.nginx.org/unit/ubuntu/ xenial unit

3、安装所需核心包及其他包:

# apt update
# apt install unit
# apt install unit-dev unit-go unit-jsc8 unit-perl unit-php \
   unit-python2.7 unit-python3.5 unit-ruby

注:

控制套接字路径名:/var/run/control.unit.sock;日志文件路径名:/var/log/unit.log;非特权进程用户:unit:unit。

results matching ""

    No results matching ""