浏览 5.3k
有没有遇到不生效的朋友,默认读取的还是系统设置。

按点赞数排序
按时间排序
在配置多个监听器时,有报too many open files
1.是root用户启动的nginx
2.limits.conf中配置的1000000
3.nginx.conf中worker_rlimit_nofile 配置的655350,worker_processes配置的10,worker_connections配置的65535
1
回答于2020-11-12 21:25
你好Omg,直播中你提的问题,就是这个问题吗?我们互动解决下看看。你是看到too many open file错误了吗?
对于worker_rlimit_nofile指令,Nginx其实是调用Linux的setrlimit(RLIMIT_NOFILE, &rlmt)函数实现的,它与ulimit -n命令行相似,同时受制于2个条件:
1、所在用户组的句柄数。你是用root用户启动Nginx的吗?
2、/proc/sys/fs/nr_open系统级限制。这个值是多少?
持久化配置到文件/etc/security/limits.conf也是不错的。
1
回答于2020-11-05 21:21
0
回答于2020-11-12 13:30
Engine:
Version: 19.03.13
API version: 1.40 (minimum version 1.12)
Go version: go1.13.15
Git commit: 4484c46d9d
Built: Wed Sep 16 17:02:21 2020
OS/Arch: linux/amd64
可以尝试优化https的配置:
ssl_session_timeout 1d;
ssl_session_cache shared:SSL:50m;
ssl_session_tickets off;
微信公众号
加入微信群