回答
收藏
分享
举报
nginx修改了limit_req_zone的key后reload不生效
提问于2022-09-12 11:01

浏览 4.5k

我的nginx的限流配置为limit_req_zone $binary_remote_addr zone=reqconsole1:100m rate=1000r/s;我修改limit_req_zone的key从binary_remote_addr为client_real_ip,在reload nginx进程时error日志报错limit_req "reqconsole" uses the "$client_real_ip" key while previously it used the "$binary_remote_addr" key。并且nginx reload并不生效
这个和nginx reload时共享内存不释放有关系吗?是什么原因导致的呢?

已修改于2023-03-17 02:27



写下您的回答
发表回答
全部回答(0)

按点赞数排序

按时间排序

提问者
森
这家伙很懒还未留下介绍~
0
文章
1
问答
0
粉丝
相关问答

”应用服务session 会失效“ 能详细说一下这个问题和现象吗?

点赞 0
浏览 3.6k

RFC规范上定义的options方法,可以用于获取所有支持的method方法。

然而,这实际上会带来web安全问题,黑客很容易扫描到web框架的漏洞,比如有些老框架还在支持trace方法。因此,waf防火墙大都会拒绝options方法。

点赞 0
浏览 4.5k

网络延迟,负载均衡,连接池都可能会有这种问题,如果是连接池耗尽,新请求就有可能会堆积并等待处理,导致数据丢失和混乱,调整一下大小就可以,或者是某部分后端服务器负载较重,而其他比较轻,也会导致请求堆积和数据混乱。

点赞 0
浏览 3.4k